{"action":"Upgrade exim to 4.94.2-r0 or later.","affected":[{"fixed":"4.94.2-r0","introduced":"4.88"}],"component":"exim","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.18","exploited":false,"fixed_versions":["4.94.2-r0"],"id":"tcs_01M6GMK62TY2PHN02DPNVNWQSQ","modified_at":"2026-11-03T06:32:25.537505012Z","published_at":"2021-05-06T13:15:09.587Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2020-28019","https://security.alpinelinux.org/vuln/CVE-2020-28019"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2020-28019#Alpine:v3.18/exim","url":"https://osv.dev/vulnerability/ALPINE-CVE-2020-28019"}],"summary":"Exim 4 before 4.94.2 has Improper Initialization that can lead to recursion-based stack consumption or other consequences. This occurs because use of certain getc functions is mishandled when a client"}