{"action":"Upgrade k3s to 1.18.6.1-r0 or later.","affected":[{"fixed":"1.18.6.1-r0","introduced":"0"}],"component":"k3s","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["1.18.6.1-r0"],"id":"tcs_01M6GMP7A30WCP23KB6WSBFPYT","modified_at":"2026-11-03T06:32:26.341573719Z","published_at":"2020-07-22T14:15:16.517Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2020-8559","https://security.alpinelinux.org/vuln/CVE-2020-8559"],"severity":{"label":"medium","score":6.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2020-8559#Alpine:v3.23/k3s","url":"https://osv.dev/vulnerability/ALPINE-CVE-2020-8559"}],"summary":"The Kubernetes kube-apiserver in versions v1.6-v1.15, and versions prior to v1.16.13, v1.17.9 and v1.18.6 are vulnerable to an unvalidated redirect on proxied upgrade requests that could allow an atta"}