{"action":"Upgrade qemu to 6.0.0-r1 or later.","affected":[{"fixed":"6.0.0-r1","introduced":"0"}],"component":"qemu","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.19","exploited":false,"fixed_versions":["6.0.0-r1"],"id":"tcs_01M6GN4MPXNDEXN6X9M71F8904","modified_at":"2026-11-03T06:32:26.727291742Z","published_at":"2021-05-13T16:15:07.653Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-20181","https://security.alpinelinux.org/vuln/CVE-2021-20181"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-20181#Alpine:v3.19/qemu","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-20181"}],"summary":"A race condition flaw was found in the 9pfs server implementation of QEMU up to and including 5.2.0. This flaw allows a malicious 9p client to cause a use-after-free error, potentially escalating thei"}