{"action":"Upgrade py3-saml2 to 6.5.0-r0 or later.","affected":[{"fixed":"6.5.0-r0","introduced":"0"}],"component":"py3-saml2","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["6.5.0-r0"],"id":"tcs_01M6GN7GXRF925MYTGEQ656Y97","modified_at":"2026-11-03T06:32:27.245315040Z","published_at":"2021-01-21T15:15:14.423Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-21239","https://security.alpinelinux.org/vuln/CVE-2021-21239"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-21239#Alpine:v3.23/py3-saml2","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-21239"}],"summary":"PySAML2 is a pure python implementation of SAML Version 2 Standard. PySAML2 before 6.5.0 has an improper verification of cryptographic signature vulnerability. Users of pysaml2 that use the default Cr"}