{"action":"Upgrade py3-pillow to 8.2.0-r0 or later.","affected":[{"fixed":"8.2.0-r0","introduced":"0"}],"component":"py3-pillow","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.16","exploited":false,"fixed_versions":["8.2.0-r0"],"id":"tcs_01M6GN9JG3K4JAJD0MS5FN7RHD","modified_at":"2026-11-03T06:32:27.699775705Z","published_at":"2021-06-02T16:15:08.603Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-25287","https://security.alpinelinux.org/vuln/CVE-2021-25287"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-25287#Alpine:v3.16/py3-pillow","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-25287"}],"summary":"An issue was discovered in Pillow before 8.2.0. There is an out-of-bounds read in J2kDecode, in j2ku_graya_la."}