{"action":"Upgrade jenkins to 2.164.2-r0 or later.","affected":[{"fixed":"2.164.2-r0","introduced":"0"}],"component":"jenkins","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.9","exploited":false,"fixed_versions":["2.164.2-r0"],"id":"tcs_01M6GP1J930GW9GY1FFWX2RZMA","modified_at":"2026-11-03T06:32:28.776202890Z","published_at":"2019-04-10T21:29:01.513Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-1003050","https://security.alpinelinux.org/vuln/CVE-2019-1003050"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-1003050","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-1003050"}],"summary":"The f:validateButton form control for the Jenkins UI did not properly escape job URLs in Jenkins 2.171 and earlier and Jenkins LTS 2.164.1 and earlier, resulting in a cross-site scripting (XSS) vulner"}