{"action":"Upgrade knot-resolver to 4.1.0-r0 or later.","affected":[{"fixed":"4.1.0-r0","introduced":"0"}],"component":"knot-resolver","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.12","exploited":false,"fixed_versions":["4.1.0-r0"],"id":"tcs_01M6GP2WWNE1EM9DZATBWHHF7Y","modified_at":"2026-11-03T06:32:28.974222293Z","published_at":"2019-07-16T18:15:12.180Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-10191","https://security.alpinelinux.org/vuln/CVE-2019-10191"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-10191#Alpine:v3.12/knot-resolver","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-10191"}],"summary":"A vulnerability was discovered in DNS resolver of knot resolver before version 4.1.0 which allows remote attackers to downgrade DNSSEC-secure domains to DNSSEC-insecure state, opening possibility of d"}