{"action":"Upgrade libsoup to 2.66.2-r2 or later.","affected":[{"fixed":"2.66.2-r2","introduced":"2.65.1"}],"component":"libsoup","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.10","exploited":false,"fixed_versions":["2.66.2-r2"],"id":"tcs_01M6GPH67SCCCMF2N2XVW991QZ","modified_at":"2026-11-03T06:32:29.538874773Z","published_at":"2019-10-06T22:15:10.367Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-17266","https://security.alpinelinux.org/vuln/CVE-2019-17266"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-17266","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-17266"}],"summary":"libsoup from versions 2.65.1 until 2.68.1 have a heap-based buffer over-read because soup_ntlm_parse_challenge() in soup-auth-ntlm.c does not properly check an NTLM message's length before proceeding"}