{"action":"Upgrade synapse to 1.21.1-r0 or later.","affected":[{"fixed":"1.21.1-r0","introduced":"0"}],"component":"synapse","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.22","exploited":false,"fixed_versions":["1.21.1-r0"],"id":"tcs_01M6GQE76N6J1YA4B9BJYHTVQG","modified_at":"2026-11-03T06:32:31.249599439Z","published_at":"2020-10-19T17:15:13.220Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2020-26891","https://security.alpinelinux.org/vuln/CVE-2020-26891"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2020-26891#Alpine:v3.22/synapse","url":"https://osv.dev/vulnerability/ALPINE-CVE-2020-26891"}],"summary":"AuthRestServlet in Matrix Synapse before 1.21.0 is vulnerable to XSS due to unsafe interpolation of the session GET parameter. This allows a remote attacker to execute an XSS attack on the domain Syna"}