{"action":"Upgrade jenkins to 2.287-r0 or later.","affected":[{"fixed":"2.287-r0","introduced":"0"}],"component":"jenkins","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.18","exploited":false,"fixed_versions":["2.287-r0"],"id":"tcs_01M6GQHHGSP327V64KYV76GYYA","modified_at":"2026-11-03T06:32:31.808134534Z","published_at":"2021-04-07T14:15:16.890Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-21639","https://security.alpinelinux.org/vuln/CVE-2021-21639"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-21639#Alpine:v3.18/jenkins","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-21639"}],"summary":"Jenkins 2.286 and earlier, LTS 2.277.1 and earlier does not validate the type of object created after loading the data submitted to the `config.xml` REST API endpoint of a node, allowing attackers wit"}