{"action":"Upgrade nodejs-current to 16.6.2-r0 or later.","affected":[{"fixed":"16.6.2-r0","introduced":"0"}],"component":"nodejs-current","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.15","exploited":false,"fixed_versions":["16.6.2-r0"],"id":"tcs_01M6GQHPRTPGPPBEBVCVXYFW3D","modified_at":"2026-11-03T06:32:31.867867208Z","published_at":"2021-08-16T19:15:13.127Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-22931","https://security.alpinelinux.org/vuln/CVE-2021-22931"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-22931#Alpine:v3.15/nodejs-current","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-22931"}],"summary":"Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to Remote Code Execution, XSS, Application crashes due to missing input validation of host names returned by Domain Name Servers in Node.js dn"}