{"action":"Upgrade py3-pillow to 8.4.0-r0 or later.","affected":[{"fixed":"8.4.0-r0","introduced":"0"}],"component":"py3-pillow","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.19","exploited":false,"fixed_versions":["8.4.0-r0"],"id":"tcs_01M6GQJ162C05919416JS43M5V","modified_at":"2026-11-03T06:32:31.981876468Z","published_at":"2021-09-03T16:15:08.317Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-23437","https://security.alpinelinux.org/vuln/CVE-2021-23437"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-23437#Alpine:v3.19/py3-pillow","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-23437"}],"summary":"The package pillow 5.2.0 and before 8.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the getrgb function."}