{"action":"Upgrade nodejs-current to 16.6.0-r0 or later.","affected":[{"fixed":"16.6.0-r0","introduced":"0"}],"component":"nodejs-current","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.19","exploited":false,"fixed_versions":["16.6.0-r0"],"id":"tcs_01M6GQJB4049B5VSCYM4CG82X6","modified_at":"2026-11-03T06:32:32.030702152Z","published_at":"2021-10-07T14:15:08.053Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-22930","https://security.alpinelinux.org/vuln/CVE-2021-22930"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-22930#Alpine:v3.19/nodejs-current","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-22930"}],"summary":"Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior."}