{"action":"Upgrade nodejs-current to 15.10.0-r0 or later.","affected":[{"fixed":"15.10.0-r0","introduced":"0"}],"component":"nodejs-current","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["15.10.0-r0"],"id":"tcs_01M6GQJEXY3GDME1S1J189NQJ3","modified_at":"2026-11-03T06:32:32.032221313Z","published_at":"2021-03-03T18:15:14.957Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-22884","https://security.alpinelinux.org/vuln/CVE-2021-22884"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-22884#Alpine:v3.23/nodejs-current","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-22884"}],"summary":"Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to DNS rebinding attacks as the whitelist includes “localhost6”. When “localhost6” is not present in /etc/hosts, it is just an ordin"}