{"action":"Upgrade go to 1.16.4-r0 or later.","affected":[{"fixed":"1.16.4-r0","introduced":"1.16.0"}],"component":"go","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.20","exploited":false,"fixed_versions":["1.16.4-r0"],"id":"tcs_01M6GR4JSA02W2FC73R4TSWTEE","modified_at":"2026-11-03T06:32:33.307382260Z","published_at":"2021-05-27T13:15:08.207Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-31525","https://security.alpinelinux.org/vuln/CVE-2021-31525"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-31525#Alpine:v3.20/go","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-31525"}],"summary":"net/http in Go before 1.15.12 and 1.16.x before 1.16.4 allows remote attackers to cause a denial of service (panic) via a large header to ReadRequest or ReadResponse. Server, Transport, and Client can"}