{"action":"Upgrade prosody to 0.11.9-r0 or later.","affected":[{"fixed":"0.11.9-r0","introduced":"0"}],"component":"prosody","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.12","exploited":false,"fixed_versions":["0.11.9-r0"],"id":"tcs_01M6GRK7S1DBAM8SHQA2VFY9XN","modified_at":"2026-11-03T06:32:33.607333046Z","published_at":"2021-05-13T16:15:08.407Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-32921","https://security.alpinelinux.org/vuln/CVE-2021-32921"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-32921","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-32921"}],"summary":"An issue was discovered in Prosody before 0.11.9. It does not use a constant-time algorithm for comparing certain secret strings when running under Lua 5.2 or later. This can potentially be used in a"}