{"action":"Upgrade py3-waitress to 1.4.1-r0 or later.","affected":[{"fixed":"1.4.1-r0","introduced":"0"}],"component":"py3-waitress","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.11","exploited":false,"fixed_versions":["1.4.1-r0"],"id":"tcs_01M6GSBSNC5AAM57P7PC2F9PGE","modified_at":"2026-11-03T06:32:35.038378121Z","published_at":"2019-12-26T17:15:13.707Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-16789","https://security.alpinelinux.org/vuln/CVE-2019-16789"],"severity":{"label":"high","score":8.2},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-16789","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-16789"}],"summary":"In Waitress through version 1.4.0, if a proxy server is used in front of waitress, an invalid request may be sent by an attacker that bypasses the front-end and is parsed differently by waitress leadi"}