{"action":"Upgrade jenkins to 2.228-r0 or later.","affected":[{"fixed":"2.228-r0","introduced":"0"}],"component":"jenkins","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.21","exploited":false,"fixed_versions":["2.228-r0"],"id":"tcs_01M6GSS4W1W5M19HBS018BD4XT","modified_at":"2026-11-03T06:32:36.703456918Z","published_at":"2020-03-25T17:15:15.093Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2020-2162","https://security.alpinelinux.org/vuln/CVE-2020-2162"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2020-2162#Alpine:v3.21/jenkins","url":"https://osv.dev/vulnerability/ALPINE-CVE-2020-2162"}],"summary":"Jenkins 2.227 and earlier, LTS 2.204.5 and earlier does not set Content-Security-Policy headers for files uploaded as file parameters to a build, resulting in a stored XSS vulnerability."}