{"action":"Upgrade imagemagick to 7.0.10.42-r0 or later.","affected":[{"fixed":"7.0.10.42-r0","introduced":"6.9.8-1"}],"component":"imagemagick","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.20","exploited":false,"fixed_versions":["7.0.10.42-r0"],"id":"tcs_01M6GTAAFZSFPP1A42AWPTTYPK","modified_at":"2026-11-03T06:32:37.261421219Z","published_at":"2020-12-07T20:15:12.773Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2020-29599","https://security.alpinelinux.org/vuln/CVE-2020-29599"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2020-29599#Alpine:v3.20/imagemagick","url":"https://osv.dev/vulnerability/ALPINE-CVE-2020-29599"}],"summary":"ImageMagick before 6.9.11-40 and 7.x before 7.0.10-40 mishandles the -authenticate option, which allows setting a password for password-protected PDF files. The user-controlled password was not proper"}