{"action":"Upgrade weechat to 2.7.1-r0 or later.","affected":[{"fixed":"2.7.1-r0","introduced":"0.3.8"}],"component":"weechat","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.20","exploited":false,"fixed_versions":["2.7.1-r0"],"id":"tcs_01M6GTBGJVC0VWQB8ZCTM7ACZ4","modified_at":"2026-11-03T06:32:37.812760089Z","published_at":"2020-02-12T22:15:13.207Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2020-8955","https://security.alpinelinux.org/vuln/CVE-2020-8955"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2020-8955#Alpine:v3.20/weechat","url":"https://osv.dev/vulnerability/ALPINE-CVE-2020-8955"}],"summary":"irc_mode_channel_update in plugins/irc/irc-mode.c in WeeChat through 2.7 allows remote attackers to cause a denial of service (buffer overflow and application crash) or possibly have unspecified other"}