{"action":"Upgrade nodejs-current to 16.11.1-r0 or later.","affected":[{"fixed":"16.11.1-r0","introduced":"0"}],"component":"nodejs-current","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.14","exploited":false,"fixed_versions":["16.11.1-r0"],"id":"tcs_01M6GTZ61Y1ZX1STDMHQBFHGXA","modified_at":"2026-11-03T06:32:38.233139521Z","published_at":"2021-11-15T15:15:06.747Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-22959","https://security.alpinelinux.org/vuln/CVE-2021-22959"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-22959#Alpine:v3.14/nodejs-current","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-22959"}],"summary":"The parser in accepts requests with a space (SP) right after the header name before the colon. This can lead to HTTP Request Smuggling (HRS) in llhttp < v2.1.4 and < v6.0.6."}