{"action":"Upgrade exim to 4.94.2-r0 or later.","affected":[{"fixed":"4.94.2-r0","introduced":"0"}],"component":"exim","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.13","exploited":false,"fixed_versions":["4.94.2-r0"],"id":"tcs_01M6GV5CJ5SDMCKZP58QR5V81M","modified_at":"2026-11-03T06:32:38.625812576Z","published_at":"2021-05-06T13:15:12.447Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-27216","https://security.alpinelinux.org/vuln/CVE-2021-27216"],"severity":{"label":"medium","score":6.3},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-27216","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-27216"}],"summary":"Exim 4 before 4.94.2 has Execution with Unnecessary Privileges. By leveraging a delete_pid_file race condition, a local user can delete arbitrary files as root. This involves the -oP and -oPX options."}