{"action":"Upgrade xwayland to 21.1.0-r4 or later.","affected":[{"fixed":"21.1.0-r4","introduced":"0"}],"component":"xwayland","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.16","exploited":false,"fixed_versions":["21.1.0-r4"],"id":"tcs_01M6GVKSS59Y5AAM8ZGKHG95YS","modified_at":"2026-11-03T06:32:40.501676623Z","published_at":"2021-04-26T15:15:07.857Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-3472","https://security.alpinelinux.org/vuln/CVE-2021-3472"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-3472#Alpine:v3.16/xwayland","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-3472"}],"summary":"A flaw was found in xorg-x11-server in versions before 1.20.11. An integer underflow can occur in xserver which can lead to a local privilege escalation. The highest threat from this vulnerability is"}