{"action":"Upgrade xorg-server to 21.1.2-r0 or later.","affected":[{"fixed":"21.1.2-r0","introduced":"0"}],"component":"xorg-server","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.20","exploited":false,"fixed_versions":["21.1.2-r0"],"id":"tcs_01M6GW7ZXAVWNBE6P1EYPCTHWF","modified_at":"2026-11-03T06:32:41.202095438Z","published_at":"2021-12-17T17:15:13.357Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-4008","https://security.alpinelinux.org/vuln/CVE-2021-4008"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-4008#Alpine:v3.20/xorg-server","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-4008"}],"summary":"A flaw was found in xorg-x11-server in versions before 21.1.2 and before 1.20.14. An out-of-bounds access can occur in the SProcRenderCompositeGlyphs function. The highest threat from this vulnerabili"}