{"action":"Upgrade npm to 8.1.4-r0 or later.","affected":[{"fixed":"8.1.4-r0","introduced":"7.0.0"}],"component":"npm","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.21","exploited":false,"fixed_versions":["8.1.4-r0"],"id":"tcs_01M6GWBP06TSFWA919TSP4K4E5","modified_at":"2026-11-03T06:32:41.511473867Z","published_at":"2021-11-13T18:15:07.537Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-43616","https://security.alpinelinux.org/vuln/CVE-2021-43616"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-43616#Alpine:v3.21/npm","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-43616"}],"summary":"The npm ci command in npm 7.x and 8.x through 8.1.3 proceeds with an installation even if dependency information in package-lock.json differs from package.json. This behavior is inconsistent with the"}