{"action":"Upgrade njs to 0.7.3-r0 or later.","affected":[{"fixed":"0.7.3-r0","introduced":"0"}],"component":"njs","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.19","exploited":false,"fixed_versions":["0.7.3-r0"],"id":"tcs_01M6GWP7MPK59HS2ERTMWAV8SZ","modified_at":"2026-11-03T06:32:42.097556077Z","published_at":"2022-02-14T22:15:07.757Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-46462","https://security.alpinelinux.org/vuln/CVE-2021-46462"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-46462#Alpine:v3.19/njs","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-46462"}],"summary":"njs through 0.7.1, used in NGINX, was discovered to contain a segmentation violation via njs_object_set_prototype in /src/njs_object.c."}