{"action":"Upgrade njs to 0.7.1-r0 or later.","affected":[{"fixed":"0.7.1-r0","introduced":"0"}],"component":"njs","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.18","exploited":false,"fixed_versions":["0.7.1-r0"],"id":"tcs_01M6GWPSTHCZRRZA798H94APPP","modified_at":"2026-11-03T06:32:42.148376867Z","published_at":"2022-02-14T22:15:07.717Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-46461","https://security.alpinelinux.org/vuln/CVE-2021-46461"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-46461#Alpine:v3.18/njs","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-46461"}],"summary":"njs through 0.7.0, used in NGINX, was discovered to contain an out-of-bounds array access via njs_vmcode_typeof in /src/njs_vmcode.c."}