{"action":"Upgrade njs to 0.7.3-r0 or later.","affected":[{"fixed":"0.7.3-r0","introduced":"0"}],"component":"njs","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.15","exploited":false,"fixed_versions":["0.7.3-r0"],"id":"tcs_01M6GWPZPQWMYRWEN8PP2D093W","modified_at":"2026-11-03T06:32:42.156139399Z","published_at":"2022-02-14T22:15:07.793Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2021-46463","https://security.alpinelinux.org/vuln/CVE-2021-46463"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2021-46463#Alpine:v3.15/njs","url":"https://osv.dev/vulnerability/ALPINE-CVE-2021-46463"}],"summary":"njs through 0.7.1, used in NGINX, was discovered to contain a control flow hijack caused by a Type Confusion vulnerability in njs_promise_perform_then()."}