{"action":"Upgrade composer to 2.7.7-r0 or later.","affected":[{"fixed":"2.7.7-r0","introduced":"0"}],"component":"composer","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.20","exploited":false,"fixed_versions":["2.7.7-r0"],"id":"tcs_01M6GXXFJTP9QPJPB0F1P79SST","modified_at":"2026-11-03T06:32:45.452578815Z","published_at":"2024-06-10T22:15:09.893Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2024-35242","https://security.alpinelinux.org/vuln/CVE-2024-35242"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2024-35242#Alpine:v3.20/composer","url":"https://osv.dev/vulnerability/ALPINE-CVE-2024-35242"}],"summary":"Composer is a dependency manager for PHP. On the 2.x branch prior to versions 2.2.24 and 2.7.7, the `composer install` command running inside a git/hg repository which has specially crafted branch nam"}