{"action":"Upgrade perl-email-mime to 1.954-r0 or later.","affected":[{"fixed":"1.954-r0","introduced":"0"}],"component":"perl-email-mime","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["1.954-r0"],"id":"tcs_01M6GXY7ZY1Q9ZVMX5JM3M2Y71","modified_at":"2026-11-03T06:32:45.457424532Z","published_at":"2024-05-02T20:15:07.333Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2024-4140","https://security.alpinelinux.org/vuln/CVE-2024-4140"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2024-4140#Alpine:v3.24/perl-email-mime","url":"https://osv.dev/vulnerability/ALPINE-CVE-2024-4140"}],"summary":"An excessive memory use issue (CWE-770) exists in Email-MIME, before version 1.954, which can cause denial of service when parsing multipart MIME messages. The patch set (from 2020 and 2024) limits ex"}