{"action":"Upgrade netatalk to 3.1.19-r0 or later.","affected":[{"fixed":"3.1.19-r0","introduced":"2.0.0"}],"component":"netatalk","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.20","exploited":false,"fixed_versions":["3.1.19-r0"],"id":"tcs_01M6GY9AP54DFF37ZFE6AQ9XMA","modified_at":"2026-11-03T06:32:45.468634270Z","published_at":"2024-06-16T13:15:53.147Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2024-38440","https://security.alpinelinux.org/vuln/CVE-2024-38440"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2024-38440","url":"https://osv.dev/vulnerability/ALPINE-CVE-2024-38440"}],"summary":"Netatalk before 3.2.1 has an off-by-one error, and resultant heap-based buffer overflow and segmentation violation, because of incorrectly using FPLoginExt in BN_bin2bn in etc/uams/uams_dhx_pam.c. The"}