{"action":"Upgrade exim to 4.94.2-r0 or later.","affected":[{"fixed":"4.94.2-r0","introduced":"4.00"}],"component":"exim","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["4.94.2-r0"],"id":"tcs_01M6GYA7EG4VGTHPV697MNQVYK","modified_at":"2026-11-03T06:32:46.000886954Z","published_at":"2021-05-06T13:15:09.403Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2020-28012","https://security.alpinelinux.org/vuln/CVE-2020-28012"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2020-28012#Alpine:v3.23/exim","url":"https://osv.dev/vulnerability/ALPINE-CVE-2020-28012"}],"summary":"Exim 4 before 4.94.2 allows Exposure of File Descriptor to Unintended Control Sphere because rda_interpret uses a privileged pipe that lacks a close-on-exec flag."}