{"action":"Upgrade xrdp to 0.9.23-r0 or later.","affected":[{"fixed":"0.9.23-r0","introduced":"0"}],"component":"xrdp","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.19","exploited":false,"fixed_versions":["0.9.23-r0"],"id":"tcs_01M6GZM90KDSP409JEVCMVGXNC","modified_at":"2026-11-03T06:32:48.847116194Z","published_at":"2023-08-30T18:15:09.690Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2023-40184","https://security.alpinelinux.org/vuln/CVE-2023-40184"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2023-40184#Alpine:v3.19/xrdp","url":"https://osv.dev/vulnerability/ALPINE-CVE-2023-40184"}],"summary":"xrdp is an open source remote desktop protocol (RDP) server. In versions prior to 0.9.23 improper handling of session establishment errors allows bypassing OS-level session restrictions. The `auth_sta"}