{"action":"Upgrade cacti to 1.2.27-r0 or later.","affected":[{"fixed":"1.2.27-r0","introduced":"0"}],"component":"cacti","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["1.2.27-r0"],"id":"tcs_01M6H01R0VT0ZH0HP3KHNFSWT9","modified_at":"2026-11-03T06:32:49.638670103Z","published_at":"2024-05-14T15:25:26.110Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2024-31459","https://security.alpinelinux.org/vuln/CVE-2024-31459"],"severity":{"label":"high","score":7.2},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2024-31459#Alpine:v3.23/cacti","url":"https://osv.dev/vulnerability/ALPINE-CVE-2024-31459"}],"summary":"Cacti provides an operational monitoring and fault management framework. Prior to version 1.2.27, there is a file inclusion issue in the `lib/plugin.php` file. Combined with SQL injection vulnerabilit"}