{"action":"Upgrade caddy to 2.11.2-r0 or later.","affected":[{"fixed":"2.11.2-r0","introduced":"2.10.0"}],"component":"caddy","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["2.11.2-r0"],"id":"tcs_01M6H2ACWNACK1W32YCT2S4DJN","modified_at":"2026-11-03T06:32:53.777082203Z","published_at":"2026-03-07T17:15:52.540Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-30851","https://security.alpinelinux.org/vuln/CVE-2026-30851"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-30851","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-30851"}],"summary":"Caddy is an extensible server platform that uses TLS by default. From version 2.10.0 to before version 2.11.2, forward_auth copy_headers does not strip client-supplied headers, allowing identity injec"}