{"action":"Upgrade xrdp to 0.10.6-r0 or later.","affected":[{"fixed":"0.10.6-r0","introduced":"0"}],"component":"xrdp","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["0.10.6-r0"],"id":"tcs_01M6H2CK56JYM3SBNJ32AY7C2W","modified_at":"2026-11-03T06:32:54.427523518Z","published_at":"2026-04-17T21:16:32.963Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-33689","https://security.alpinelinux.org/vuln/CVE-2026-33689"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-33689","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-33689"}],"summary":"xrdp is an open source RDP server. Versions through 0.10.5 have an out-of-bounds read vulnerability in the pre-authentication RDP message parsing logic. A remote, unauthenticated attacker can trigger"}