{"action":"Upgrade xrdp to 0.10.6-r0 or later.","affected":[{"fixed":"0.10.6-r0","introduced":"0"}],"component":"xrdp","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["0.10.6-r0"],"id":"tcs_01M6H2D46MH9MF9NARW9JQM9YG","modified_at":"2026-11-03T06:32:54.628114021Z","published_at":"2026-04-17T20:16:34.723Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-33516","https://security.alpinelinux.org/vuln/CVE-2026-33516"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-33516#Alpine:v3.24/xrdp","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-33516"}],"summary":"xrdp is an open source RDP server. Versions through 0.10.5 contain an out-of-bounds read vulnerability during the RDP capability exchange phase. The issue occurs when memory is accessed before validat"}