{"action":"Upgrade composer to 2.9.6-r0 or later.","affected":[{"fixed":"2.9.6-r0","introduced":"1.0.0"}],"component":"composer","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["2.9.6-r0"],"id":"tcs_01M6H2X83P7XSZV334WNJTD1F1","modified_at":"2026-11-03T06:32:55.447262221Z","published_at":"2026-04-15T21:17:27.693Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-40261","https://security.alpinelinux.org/vuln/CVE-2026-40261"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-40261#Alpine:v3.24/composer","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-40261"}],"summary":"Composer is a dependency manager for PHP. Versions 1.0 through 2.2.26 and 2.3 through 2.9.5 contain a command injection vulnerability in the Perforce::syncCodeBase() method, which appends the $sourceR"}