{"action":"Upgrade composer to 2.9.8-r0 or later.","affected":[{"fixed":"2.9.8-r0","introduced":"0"}],"component":"composer","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["2.9.8-r0"],"id":"tcs_01M6H3EJABGWGC2BN7KN0R7NPQ","modified_at":"2026-11-03T06:32:55.940420774Z","published_at":"2026-07-15T17:16:48.173Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-45793","https://security.alpinelinux.org/vuln/CVE-2026-45793"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-45793","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-45793"}],"summary":"Composer is a dependency Manager for the PHP language. Prior to 1.10.28, 2.2.28, and 2.9.8, Composer\\IO\\BaseIO::loadConfiguration() validates GitHub OAuth tokens with the regex ^[.A-Za-z0-9_]+$ and in"}