{"action":"Upgrade npm to 10.9.1-r0 or later.","affected":[{"fixed":"10.9.1-r0","introduced":"0"}],"component":"npm","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["10.9.1-r0"],"id":"tcs_01M6H6A0Y3882TDH87ZKX6PZ1S","modified_at":"2026-11-03T06:32:59.805816Z","published_at":"2024-11-08T05:15:06.453Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2024-21538","https://security.alpinelinux.org/vuln/CVE-2024-21538"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2024-21538#Alpine:v3.24/npm","url":"https://osv.dev/vulnerability/ALPINE-CVE-2024-21538"}],"summary":"Versions of the package cross-spawn before 6.0.6, from 7.0.0 and before 7.0.5 are vulnerable to Regular Expression Denial of Service (ReDoS) due to improper input sanitization. An attacker can increas"}