{"action":"Upgrade neatvnc to 0.8.1-r0 or later.","affected":[{"fixed":"0.8.1-r0","introduced":"0"}],"component":"neatvnc","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.20","exploited":false,"fixed_versions":["0.8.1-r0"],"id":"tcs_01M6H6ABB1Y0F45Y4C3K276GDN","modified_at":"2026-11-03T06:32:59.909785478Z","published_at":"2024-08-02T04:17:30.593Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2024-42458","https://security.alpinelinux.org/vuln/CVE-2024-42458"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2024-42458","url":"https://osv.dev/vulnerability/ALPINE-CVE-2024-42458"}],"summary":"server.c in Neat VNC (aka neatvnc) before 0.8.1 does not properly validate the security type, a related issue to CVE-2006-2369."}