{"action":"Upgrade lite-xl to 2.1.8-r0 or later.","affected":[{"fixed":"2.1.8-r0","introduced":"0"}],"component":"lite-xl","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.22","exploited":false,"fixed_versions":["2.1.8-r0"],"id":"tcs_01M6H6B0J58FMTH1258FPE9JJ4","modified_at":"2026-11-03T06:33:00.129536434Z","published_at":"2025-11-20T17:15:48.787Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2025-12121","https://security.alpinelinux.org/vuln/CVE-2025-12121"],"severity":{"label":"high","score":7.3},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2025-12121","url":"https://osv.dev/vulnerability/ALPINE-CVE-2025-12121"}],"summary":"Lite XL versions 2.1.8 and prior contain a vulnerability in the system.exec function, which allowed arbitrary command execution through unsanitized shell command construction. This function was used i"}