{"action":"Upgrade libssh to 0.11.2-r0 or later.","affected":[{"fixed":"0.11.2-r0","introduced":"0"}],"component":"libssh","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.22","exploited":false,"fixed_versions":["0.11.2-r0"],"id":"tcs_01M6H6YXWE4HCFVWRDWTCW26XC","modified_at":"2026-11-03T06:33:00.747486689Z","published_at":"2025-07-04T06:15:24.930Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2025-5372","https://security.alpinelinux.org/vuln/CVE-2025-5372"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2025-5372","url":"https://osv.dev/vulnerability/ALPINE-CVE-2025-5372"}],"summary":"A flaw was found in libssh versions built with OpenSSL versions older than 3.0, specifically in the ssh_kdf() function responsible for key derivation. Due to inconsistent interpretation of return valu"}