{"action":"Upgrade xrdp to 0.10.5-r0 or later.","affected":[{"fixed":"0.10.5-r0","introduced":"0"}],"component":"xrdp","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["0.10.5-r0"],"id":"tcs_01M6H7F75J9BVE6Z9CM0AKM47R","modified_at":"2026-11-03T06:33:01.063986080Z","published_at":"2026-01-27T16:16:16.037Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2025-68670","https://security.alpinelinux.org/vuln/CVE-2025-68670"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2025-68670#Alpine:v3.24/xrdp","url":"https://osv.dev/vulnerability/ALPINE-CVE-2025-68670"}],"summary":"xrdp is an open source RDP server. xrdp before v0.10.5 contains an unauthenticated stack-based buffer overflow vulnerability. The issue stems from improper bounds checking when processing user domain"}