{"action":"Upgrade pnpm to 10.33.4-r0 or later.","affected":[{"fixed":"10.33.4-r0","introduced":"6.25.0"}],"component":"pnpm","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["10.33.4-r0"],"id":"tcs_01M6H7F7BQNXJENZYP1M4E6ERY","modified_at":"2026-11-03T06:33:01.066953794Z","published_at":"2026-01-07T23:15:50.330Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2025-69262","https://security.alpinelinux.org/vuln/CVE-2025-69262"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2025-69262","url":"https://osv.dev/vulnerability/ALPINE-CVE-2025-69262"}],"summary":"pnpm is a package manager. Versions 6.25.0 through 10.26.2 have a Command Injection vulnerability when using environment variable substitution in .npmrc configuration files with tokenHelper settings."}