{"action":"Upgrade gradle to 8.14.4-r0 or later.","affected":[{"introduced":"9.0.0"}],"component":"gradle","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["8.14.4-r0"],"id":"tcs_01M6H815XZBEHATZ4P672RXJSS","modified_at":"2026-11-03T06:33:01.769361719Z","published_at":"2026-01-16T23:15:50.127Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-22816","https://security.alpinelinux.org/vuln/CVE-2026-22816"],"severity":{"label":"high","score":7.4},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-22816#Alpine:v3.24/gradle","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-22816"}],"summary":"Gradle is a build automation tool, and its native-platform tool provides Java bindings for native APIs. When resolving dependencies in versions before 9.3.0, some exceptions were not treated as fatal"}