{"action":"Upgrade caddy to 2.11.1-r0 or later.","affected":[{"fixed":"2.11.1-r0","introduced":"0"}],"component":"caddy","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["2.11.1-r0"],"id":"tcs_01M6H8MKM0HZV3ENTGJ60ZNB3W","modified_at":"2026-11-03T06:33:02.010242930Z","published_at":"2026-02-24T17:29:03.793Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-27586","https://security.alpinelinux.org/vuln/CVE-2026-27586"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-27586#Alpine:v3.24/caddy","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-27586"}],"summary":"Caddy is an extensible server platform that uses TLS by default. Prior to version 2.11.1, two swallowed errors in `ClientAuthentication.provision()` cause mTLS client certificate authentication to sil"}