{"action":"Upgrade nats-server to 2.12.6-r0 or later.","affected":[{"fixed":"2.12.6-r0","introduced":"2.12.0"}],"component":"nats-server","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["2.12.6-r0"],"id":"tcs_01M6H8PPCVK1E00TSFAS36VRGP","modified_at":"2026-11-03T06:33:02.409367463Z","published_at":"2026-03-25T20:16:32.623Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-33218","https://security.alpinelinux.org/vuln/CVE-2026-33218"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-33218","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-33218"}],"summary":"NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Prior to versions 2.11.15 and 2.12.6, a client which can connect to the leafnode port can crash the nats"}