{"action":"Upgrade composer to 2.9.6-r0 or later.","affected":[{"fixed":"2.9.6-r0","introduced":"1.0.0"}],"component":"composer","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["2.9.6-r0"],"id":"tcs_01M6H96MP10J33P6MKNDN56D0Z","modified_at":"2026-11-03T06:33:02.763970838Z","published_at":"2026-04-15T21:17:27.357Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-40176","https://security.alpinelinux.org/vuln/CVE-2026-40176"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-40176#Alpine:v3.24/composer","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-40176"}],"summary":"Composer is a dependency manager for PHP. Versions 1.0 through 2.2.26 and 2.3 through 2.9.5 contain a command injection vulnerability in the Perforce::generateP4Command() method, which constructs shel"}