{"action":"Upgrade wolfssl to 5.9.4-r0 or later.","affected":[{"fixed":"5.9.4-r0","introduced":"0"}],"component":"wolfssl","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["5.9.4-r0"],"id":"tcs_01M6HAWXY7ZGCQ4DAQHDNQHCRZ","modified_at":"2026-11-03T06:33:04.445406626Z","published_at":"2026-09-27T10:16:58.900Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-89133","https://security.alpinelinux.org/vuln/CVE-2026-89133"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-89133","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-89133"}],"summary":"wolfSSL versions 5.9.2 and earlier contain a flaw in the X.509 certificate validation logic where it fails to properly enforce NameConstraints extensions when there is an unconstrained CA tier between"}